First impressions: Hardy Heron (beta) and VMware Workstation 6.5 (also beta)

I just read a blog post on the Planet Gnome RSS feed by a guy who calls him self ChipX86 who said the new beta of VMware Workstation 6.5 was out. Being a major fan of Workstation since version 5.5 i decided it had to try it out immediately.

The new killer feature is obviously the Unity feature, which some might have seen in Fusion, which is VMware’s Workstation edition for MacOS X. Unity allows applications running in the guest operating system, to be accessed in the host operating system. So you could start Internet Explorer (if for example your workplace insists on using an intranet web-application that will only work in IE6… bastards), minimize the whole Windows OS, and enjoy your normal favorite flavor of Linux only slightly marred by the sight of IE6 running.

There’s lots of new stuff in version 6.5 as well, apart from just Unity. You can read them all at VMware’s documentation, but the most important ones are probably:

  • support for 3D acceleration in Windows XP – good when your developing code using Delta3D for your master thesis :-)
  • GUI for manipulating virtual network settings on Linux hosts

There’s plenty of other new stuff as well. The blog post has a pretty good walk-through of the best features of Unity.

Installation and Configuration

The download is the usual 200+ MB .tar.gz file. Un-packaging the file results in the expected vmware-install.pl script which must be run as super user. Starting the installation process the first message received was a warning that my existing Workstation 6.0 installation would be removed first. Not exactly unexpectedly but still kind of annoying. It would have been nice to have been able to keep a non-beta version installed along the beta.

Graphical installation... sort of.

The installation ran smooth, and soon asked for permission to run the vmware-config.pl script. I can’t remember when I last installed a version of VMware that didn’t require the infamous vmware-any-any patch to work on my machine, so I was actually expecting this would prove problematic. But to my surprise everything ran quietly and perfectly.

Starting Workstation after the installation gave another pleasant surprise, when the program informed me that I had to run is as super user, to load some modules into my running kernel. Much better that the “thinking-for-while-and-then-not-starting” thing that happened in version 6 when there was a problem with the modules. After aborting and restarting the program with sudo, I got a very handy graphical window showing the loading of the modules. Nice touch.

But all is not well… because right after that a new dialoge informed me that the program would be running in debug mode, which could not be turned off, and that debug mode would result in significant performance loss. To bad… it was probably to be expected, but I would actually have liked a warning before installation, especially since I had to un-install my Workstation version 6 first. I’m pretty sure the documentation says something about this some where, but a bit more prominent warning would have been nice.

Debug mode... blast!

Running Workstation 6.5 beta 1

I have just been running this new version for an hour or two, so it’s hard to come with a solid conclusion about Workstation 6.5 beta 1. Most stuff seem to be working. Programs, networking etc. I can definitely say that I didn’t get any performance improvement, but that was to be expected with all this debugging stuff. But to be fair, I didn’t really get a huge loss of performance, so I guess I’m going to have some more testing to get a qualified opinion on that.

Working as expected

So… what about Unity? Well, it works. Sort of… It’s definitely not perfect, but it can be used. Lots of times moving around the windows will result in them not getting updated/redrawn, and other strange things. But it will mostly work. I used Visual Studio, which is one of my primary reasons for using Workstation in the first place, with unity on my normal desktop for a while, and it worked fine. No real problems using the programs, and you get used to using your normal Linux productivity tools along side of the Windows apps really fast. It’s fantastic to finally be able to use Windows programs on multiple desktops, for example. That’s one the features is miss the most, when I’m finally using Windows.

Mmmm Unity

Using Unity

Unity seems to be working quite good, event though it seems to suck a lot of resources from the machine when running programs. I managed to crash it a couple of times, and at one time it actually took down Ubuntu with it. But it’s almost worth it, being able to use those few essential Windows apps, without seeing that nasty little Start button.

Rendering errors...

Further Testing

So that was just the very first and very few impression from using Workstation 6.5 beta 1 for about one and a half hour. I’ll probably give some more work tomorrow, where I need to do some .NET development, and see where it leads. I have another machine running Workstation as well, so should the need arise to use version 6.0, I’m going to be able to use that one. If you’re not so lucky, and you need a stable Workstation, you should probably wait a little while before going 6.5. But don’t miss out on trying Unity if you get the chance. I’m already looking forward to enabling some of my desktop effects, and seeing what Unity are going to do about that.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>